Perché i robot TF2 generati non si muovono?

So come generare robot con il command tf_bot_add , ma quando tf_bot_add i robot, loro tf_bot_add lì. Come faccio a farli muovere?

Primo: se la mappa ha tempo di configuration, attendere che termini; ai bot piace stare in piedi durante il setup. Se i tempi di installazione sono finiti e non si stanno ancora muovendo, questo è un problema reale.

Il problema più comune qui è la mancanza di navmeshes; i bot funzionano solo su mappe che hanno navmesh. Puoi verificare se una mappa ha una sv_cheats 1 con sv_cheats 1 nav_edit 1 ; se vedi un mucchio di rettangoli apparire sul pavimento è un navmesh. ( nav_edit 0 il display con nav_edit 0 ) Se la mappa è priva di una navmesh, puoi crearne una automatica con nav_generate (anche un command cheats).

Se il mavmesh non è il problema, probabilmente lo è il gamemode. I robot sono supportti solo ufficialmente su KOTH, Attack / Defend CP e Payload; lavorano in modo ufficioso su CTF, ma per il resto non funzionano con altri gamemode anche con un navmesh. Non c'è niente che puoi fare in questo caso aspettarti solo aspettando che il gamemode sia supportto.

Su alcune mappe, i robot possono funzionare, ma su altri non possono – come Payload Race, CTF Doomsday, MVM e Arena. Rimarranno fermi nella posizione di spawn per il motivo che non hanno istruzioni su where andare.

Per risolvere questo problema, unisciti a qualsiasi mappa (ad esempio ctf_2fort, ad esempio). Digita sv_cheats 1 nella console, quindi digita nav_generate . Non appena digiti questo, il tuo gioco rimarrà un po 'lento, quindi dovrai aspettare. Questo farà sì che i robot funzionino sulla maggior parte delle mappe (ad exception delle gare di Doomsday, MVM, Arena e Payload), ma su tutti gli altri faranno l'objective.